서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

3
Nagios에서 예정된 다운 타임을 취소하려면 어떻게해야합니까
여러 서버에 대한 Nagios 3.5.1 모니터가 있습니다. Drupal 또는 Wordpress 핵심 업그레이드와 같은 작업을 수행하면서 사이트를 다운하고 Nagios를 예정된 중단으로 설정했습니다. 때로는 2 시간 기본값으로 끝내고 중단을 무시하고 싶지 않습니다. Nagios에 완료했음을 알리고 예정된 다운 타임 을 취소 하려면 어떻게해야 합니까?
12 nagios 

1
어떤 메모리에 CE 오류가 있는지 어떻게 알 수 있습니까?
에서 /var/log/kern.log: kernel: [13291329.657499] EDAC MC0: 48 CE error on CPU#0Channel#2_DIMM#0 (channel:2 slot:0 page:0x0 offset:0x0 grain:8 syndrome:0x0) edac메모리 중 하나에 ce오류 가있는 로그 입니다. edac doc 을 읽었습니다 Dual channels allows for 128 bit data transfers to the CPU from memory. Some newer chipsets allow for more than 2 channels, …
12 memory  dmidecode 

2
업스트림 서버의 Nginx http 접두사
nginx를 사용하여 두 개의 도커 컨테이너에 프록시를 전달하려고합니다. 다음은 업스트림 conf 파일입니다. upstream api_servers { server http://192.168.49.4:49155; server http://192.168.49.4:49156; } 이것이 내가로드하려고하는 것입니다 : nginx: [emerg] invalid host in upstream "http://192.168.49.4:49155" in /etc/nginx/conf.d/api_upstream.conf:3 nginx: configuration file /etc/nginx/nginx.conf test failed http : // 접두사를 제거하면 오류가 발생하지 않습니다. 왜 그런 겁니까?
12 centos  nginx  vagrant 


2
SSLv3를 비활성화하지만 Apache에서 여전히 SSLv2Hello를 지원
JDK 6과 같은 많은 SSL 클라이언트는 SSLv2Hello 프로토콜을 사용하여 서버와 핸드 셰이크합니다. 이 프로토콜을 사용 한다고해서 SSL 2.0 또는 3.0을 사용한다는 의미 는 아닙니다 . 사용할 프로토콜을 결정 하는 것은 단지 악수 일뿐 입니다. [ http://tools.ietf.org/html/rfc5246#appendix-E.2] 그러나 Apache에서 SSLv3 지원을 사용하지 않으면 SSLv2Hello 프로토콜에 대한 지원이 제거됩니다. Apache Tomcat은 SSLv2Hello를 …

3
SSD 디스크를 안전하게 삭제하는 것과 관련된 잠재적 위험
Linux 호스팅 서버 중 하나에서 2 개의 SSD 디스크를 제거해야합니다. 디스크에 저장된 데이터를 안전하게 삭제하기 위해 사용할 계획은 다음과 같습니다 hdparm --security-erase.. 이 문서를 읽었 으며 삭제하려는 디스크 이외의 디스크를 호스트에 연결하지 말 것을 제안했습니다. 이 기사에서는 커널 또는 펌웨어 버그가있는 경우이 절차를 수행하면 드라이브를 사용할 수 없게되거나 실행중인 컴퓨터가 …

1
Elasticsearch가 디스크 공간을 너무 많이 사용하고 있습니다
Elasticsearch 1.3.2를 설치 한 CentOS 6.5 서버가 있습니다. 내 elasticsearch.yml구성 파일은 elasticsearch를 기본값으로 사용하는 것의 최소한의 수정입니다. 주석 처리 된 모든 행을 제거하면 다음과 같습니다. cluster.name: xxx-kibana node: name: "xxx" master: true data: true index.number_of_shards: 5 index.number_of_replicas: 1 path: logs: /log/elasticsearch/log data: /log/elasticsearch/data transport.tcp.port: 9300 http.port: 9200 discovery.zen.ping.multicast.enabled: false Elasticsearch는 …

1
mail.protection.outlook.com으로 보낸 메일이 수신되지 않습니다
며칠 동안 많은 구독 고객으로부터 매일 알림 메일을받지 못했다는 불만이 접수되었습니다. 로그에서 서버가 메일을 수락했음을 확인 example.com.mail.protection.outlook.com했지만 (MX 레코드 :) 이 서비스에 가입 한 모든 클라이언트가받은 편지함에 메일을받지 못했습니다. 클라이언트 메일 서버는 메일을 오류없이 허용합니다. 다음은 sendmail 서버의 로그입니다. 참고 : 유효한 SPF 레코드가 있습니다. 또한, 우리의 메일 서버는 블랙리스트에 …

3
Apache가 파일에 쓰지 못하게하는 SELinux
SELinux는 apache사용자가 자신이 소유 한 로그 파일에 쓰지 못하게합니다 . 내가 할 setenforce 0때 작동합니다. 그렇지 않으면이 오류가 표시됩니다 IOError: [Errno 13] Permission denied: '/var/www/webapp/k/site/k.log' 파일의 보안 컨텍스트 : $ ll -Z k.log -rw-r--r--. apache apache system_u:object_r:httpd_sys_content_t:s0 k.log SELinux 모드가 허용으로 설정되었을 때 파일이 작성되었습니다. apache사용자가 해당 디렉토리에 쓸 수 …

4
Docker를 사용하여 사용자를 위해 웹 사이트를 분리 할 수 ​​있습니까?
사용자가 FTP로 액세스 할 수있는 자체 웹 사이트가있는 서버 (예 : 호스팅 회사와 같은)를 관리하고 LAMP 스택 프로세스를 분리하는 대신 Docker를 구현하고 웹 사이트 당 이미지를 사용할 수 있는지 궁금합니다. 내가 이해 한 바에 따르면 포트를 통해 Docker 인스턴스를 노출 할 수 있으므로 동일한 서버에서 두 개의 docker 인스턴스를 실행하면 …
12 hosting  docker 

8
예약 된 작업으로 프로그램이 제대로 실행되지 않습니다
상태 일부 파일을 준비하고 프로그램을 실행 한 .exe다음 해당 파일을 삭제 하는 배치 스크립트가 있습니다. 이 작업은 매시간 실행되므로 예약 된 작업을 사용하여 구성하려고합니다. 문제는 이전에 언급 한 프로그램이 .bat스크립트 를 통해 또는 .exe직접 호출 할 때 작업에서 호출 할 때 제대로 실행되지 않지만 로그에 경고 또는 오류 메시지가 표시되지 …

3
RabbitMQ-다운 타임없는 업그레이드를 위해 서버를 어떻게 구성합니까?
문서와 RabbitMQ를 실제로 읽어 보면 RabbitMQ 클러스터를 만드는 것이 간단 해 보이지만 기존 RabbitMQ 클러스터를 업그레이드하거나 패치하려면 전체 클러스터를 다시 시작해야합니다. 대기열, 메시지를 잃지 않고 롤링 업그레이드를 가능하게하기 위해 클러스터링, 삽, 페더레이션 및로드 밸런싱을 결합 할 수있는 방법이 있습니까?

3
우분투에서 ipsec 확인 IP 전달을 확인하는 둘 이상의 인터페이스가 발견되었습니다. [FAILED]
우분투 14.04, 오픈 스완 U2.6.38 / K3.13.0-30- 일반 ipsec verify를 실행하면이 오류가 발생합니다. Two or more interfaces found, checking IP forwarding [FAILED] 나는이 같은 질문 중 상당수가 떠 다니는 것을 보았습니다. 아무도 해결책을 찾았습니까? 물론 sysctl.conf에서 IP 전달을 활성화했습니다 :-) 나는 많은 연구를 해왔고 이것으로 얻을 수는 없습니다.
12 ubuntu  vpn  ipsec 

3
방화벽으로 RHEL7 / CentOS7에서 나가는 연결을 차단 하시겠습니까?
RHEL7 / CentOS7은 새로운 firewalld방화벽 서비스를 제공하며,이 방화벽 서비스는 iptables service(두 가지 iptables도구를 사용 하여 아래의 커널 Netfilter와 상호 작용합니다). firewalld쉽게 들어오는 트래픽을 차단하도록 조정 할 수 있지만, 토마스 Woerner에서 언급 한 바와 같이 1,5 년 전 "나가는 트래픽을 제한하는 순간에 간단한 방법으로 firewalld 불가능합니다." 그리고 내가 볼 수있는 한 …

3
pam 구성 오류 메시지로 crontab 액세스 문제를 해결하는 방법은 무엇입니까? [닫은]
폐쇄되었습니다 . 이 질문에는 세부 사항이나 명확성 이 필요 합니다 . 현재 답변을받지 않습니다. 이 질문을 개선하고 싶습니까? 이 게시물 을 편집 하여 세부 사항을 추가하고 문제점을 명확하게하십시오 . 휴일 오년 전에 . pam 구성을 언급하는 다음 오류 메시지에 표시된 권한 문제가 발생했을 때 루트가 아닌 사용자 "coins"로 crontab에 액세스하려고했습니다. …
12 linux  cron  pam 

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.