서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
PHP에서 GD 라이브러리를 설치하는 방법?
PHP에서 imagefromjpeg () 함수를 사용하려고 할 때 오류가 발생하여 다음 명령을 사용하여 GD 라이브러리를 설치하려고했습니다. sudo apt-get install php5-gd 그러나 다음과 같은 오류가 발생했습니다. php5-gd : Depends: php5-common (= 5.5.9+dfsg-1ubuntu4) but 5.5.10+dfsg-1+deb.sury.org~saucy+1 is to be installed E: Unable to correct problems, you have held broken packages. 우분투 14.04LTS를 사용하고 있습니다. …
12 ubuntu  php  gd 

8
폴더에서 파일 만료 : x 일 후 파일 삭제
모든 사람이 액세스 할 수있는 Windows 공유 드라이브에서 "드롭 폴더"를 만들려고합니다. 파일이 X 일 이상 폴더에 있으면 자동으로 파일을 삭제하고 싶습니다. 그러나 내가 찾은 모든 방법, 마지막 수정 날짜, 마지막 액세스 시간 또는 파일 작성 날짜를 사용하는 것처럼 보입니다. 이 폴더를 사용자가 다른 사용자와 공유하기 위해 파일을 놓을 수있는 폴더로 …

1
MS SQL Server가 NTLM 인증을 사용하는 이유는 무엇입니까?
Windows Server 2008 R2 SQL Server 2008 R2가 설치되었습니다. MSSQL 서비스는 로컬 시스템으로 실행됩니다. 서버 FQDN은 SQL01.domain.com입니다. SQL01은 domain.com이라는 Active Directory 도메인에 가입되어 있습니다. 다음은 setspn의 출력입니다. C:\> setspn -L sql01 ... MSSQLSvc/SQL01.domain.com:1433 MSSQLSvc/SQL01.domain.com WSMAN/SQL01.domain.com WSMAN/SQL01 TERMSRV/SQL01.domain.com TERMSRV/SQL01 RestrictedKrbHost/SQL01 RestrictedKrbHost/SQL01.domain.com HOST/SQL01.domain.com HOST/SQL01 그런 다음 SQL Server Management Studio를 시작하고 SQL01에 …

2
비 SSD로 표시되는 RAID의 VMware ESXi SSD
KVM 서버를 ESXi 서버로 교체하고 있습니다. ESXi 5.5u1을 설치하고 데이터 저장소를 추가했습니다. 새 서버에는 하드웨어 RAID를 사용하여 RAID 6에 4 개의 SSD 드라이브가 있습니다. 데이터 저장소를 추가했을 때 VMware는 저장소가 SSD가 아니라고 말합니다. 이것이 정상입니까? 분명히 VMware는 SSD 자체가 아닌 RAID 카드에 의해 노출 된 가상 디스크를보고 있습니다. VMware에 최고의 …

2
Apache 구성을 정상적으로 다시로드하려면 SSL 인증서 비밀번호가 필요합니까?
사소한 구성 업데이트가 필요한 Apache 서버가 실행 중입니다. Apache가 설정을 다시로드하도록하고 싶습니다 (예 : /etc/init.d/httpd reload 또는 apachectl graceful). 그러나 SSL 인증서 비밀번호를 보유하지 않습니다. 비밀번호가있는 관리자는 현재 사용할 수 없습니다. 아파치 구성을 정상적으로 다시로드하면 SSL 인증서에 다시 비밀번호가 필요합니까? 아니면 서버를 완전히 다시 시작하는 동안에 만 발생합니까?

1
유일한 전자 메일 VPS 서버를 보유한 경우의 이점
VPS 서버에 약 5 개의 웹 사이트가 호스팅되어 있으며, 어떤 이유로 최근에 5 개의 웹 사이트에 대한 전자 메일을 호스팅하기 위해 다른 VPS 서버를 구입했습니다. 별도의 전자 메일 서버를 웹 호스트와 격리시키는 장단점을 알고 싶습니다. 한 서버에서 여러 소프트웨어가 실행되는 것을 피하기 위해 처음에했습니다. 따라서 PostFix, Dovecot ...와 같은 리소스는 …

2
서비스로 설치 될 때 Logstash 구성 [닫기]
닫은. 이 질문은 주제에 맞지 않습니다 . 현재 답변을받지 않습니다. 이 질문을 개선하고 싶습니까? 서버 결함에 대한 주제가 되도록 질문을 업데이트하십시오 . 휴일 오년 전에 . Ubuntu 13.10 의 logstash APT 저장소 를 사용하여 logstash를 서비스로 설치했습니다 . 이제 다음을 실행할 수 있습니다. dpkg -s logstash 그리고 그것은 출력합니다 : …
12 logstash 

2
서브 도메인 당 SSH 홈 디렉토리
각 하위 도메인에 대해 동일한 ssh 사용자에 대해 다른 홈 디렉토리를 설정할 수 있는지 궁금합니다. 따라서 ssh myuser@example.com홈 디렉토리로 로그인한다고 가정 해보십시오. /www/httpdocs/ ssh myuser@subdomain1.example.com홈 디렉토리로 로그인하면 다음과 같습니다. /www/subdomain1/ ssh myuser@subdomain2.example.com홈 디렉토리로 로그인하면 다음과 같습니다. /www/subdomain2/ ... 등등.

6
Server 2012 / R2에서 WSD (Web Services for Devices)를 비활성화 할 수 있습니까? 어떻게?
Server 2012 및 Server 2012 R2에서 WSD를 비활성화하는 방법을 찾고 있습니다. 기본적으로 다수의 인쇄 서버에있는 다수의 프린터는이 블러디 서비스를 사용하는 것이 할당 된 TCP / IP 포트를 사용하는 것보다 낫다고 결정했으며 사용자가 WSD 포트로 전환하여 사용자가 이 프린터로 인쇄하십시오. Windows 2008 R2 서버에서 PnP-X IP 버스 열거 자 서비스를 중지 …

4
24 개의 CPU 중 1 개가 100 %로 페깅 된 이유는 무엇입니까?
하이퍼 스레딩이 활성화 된 2 개의 6 코어 CPU를 사용하는 HP ProLiant DL380 G7 시스템에 총 24 개의 논리 CPU가 있습니다 (Windows에서 볼 수 있음). 응용 프로그램을 실행할 때 총 시스템 CPU 사용률은 좋지만 24 개의 CUP 중 하나가 100 %로 고정되어 있습니다. 편집 : 이 시간 동안 시스템 프로세스 …

2
zpool에서 디스크를 교체해야합니다… 혼란
FreeNAS의 zpool에서 불량 디스크를 교체해야합니다. zpool status 쇼 pool: raid-5x3 state: ONLINE scrub: scrub completed after 15h52m with 0 errors on Sun Mar 30 13:52:46 2014 config: NAME STATE READ WRITE CKSUM raid-5x3 ONLINE 0 0 0 raidz1 ONLINE 0 0 0 ada5p2 ONLINE 0 0 0 gptid/a767b8ef-1c95-11e2-af4c-f46d049aaeca ONLINE 0 …
12 freebsd  zfs  freenas  raidz  zpool 

4
다른 사용자로 스크립트 시작
나는 /etc/init.d/에 스크립트를 만들었는데 마치 마치 마치 홈 디렉토리의 다른 (루트가 아닌 권한있는) 사용자가 시작한 것처럼 다른 스크립트를 실행해야합니다. 이 스크립트를 다음과 같이 시작합니다. sudo -b -u <username> <script_of_a_particular_user> 그리고 작동합니다. 그러나 계속 실행되는 모든 사용자 스크립트 (예 : 일부 감시)에 대해 해당 부모 sudo 프로세스가 여전히 살아 있고 루트로 …
12 linux  debian  bash  sudo  init.d 


3
Amazon Route53 DNS 및 S3가 포함 된 와일드 카드 하위 도메인 (* .example.com)
DNS 용 Amazon Route53과 html 파일 용 S3을 사용하여 정적 웹 사이트를 호스팅하고 있습니다. 잘 작동합니다. 현재 설정은 다음과 같습니다 example.com. A ALIAS s3-website-us-east-1.amazonaws.com. www.example.com. CNAME www.example.com.s3-website-us-east-1.amazonaws.com (참고 : example.com 및 www.example.com은 S3 버킷입니다. HTML 파일은 example.com 버킷에 있습니다.) 이제 와일드 카드 하위 도메인을 다음과 같이 추가하고 싶습니다. *.example.com. CNAME …

14
방랑자 오류 : 연결 시간이 초과되었습니다. 재시도
Ubuntu 12.04, Virtualbox 4.3 및 Vagrant 1.5.1이있는 서버가 있습니다. 그러나이 상자 http://puppet-vagrant-boxes.puppetlabs.com/centos-64-x64-vbox4210.box 를 사용하려고합니다 . "vagrant up"을 실행하면 다음 메시지가 나타납니다. Bringing machine 'default' up with 'virtualbox' provider... ==> default: Importing base box 'centos-64-x64-vbox4210'... ==> default: Matching MAC address for NAT networking... ==> default: Setting the name of the VM: …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.