서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

1
SELinux 재설정 루트 비밀번호
면책 조항 :이 문제는 이미 해결해야 할 많은 가이드가 있기 때문에 SELinux가 활성화되어있는 동안 루트 암호 변경 문제를 해결하지는 않습니다. 이것이 SELinux가 내부적으로 수행하는 방식에 더 가깝습니다. 나는 SELinux의 최근 사용자이지만 최근에 더 많은 사람들과 연락을 취했습니다. 누군가 잊어 버린 경우 어떻게 루트 암호를 재설정 할 수 있는지 물어 보았습니다. …

8
IP를 정기적으로 변경하는 Linux 시스템에 연결하는 방법은 무엇입니까?
내 문제는 매일 IP 주소가 변경되는 Linux 서버 (Ubuntu 18.04)에 SSH하는 방법을 찾는 것입니다. 관리 작업을 도와주는 클라이언트가 있습니다. 도움이 필요할 때 컴퓨터에 ssh해야하지만 정적 IP가 없으므로 서버의 공용 IP가 지속적으로 변경됩니다. Linux 시스템의 IP 주소를보고하는 작은 스크립트를 작성했으며 정오 쯤 하루에 한 번씩 변경되는 것을 발견했습니다. SSH를 설정할 수 …

1
자체 서명 된 루트 CA가 서명 한 인증서를 무효화하지 않고 재발급
회사 내부의 일부 내부 서비스에 대해 자체 서명 된 루트 인증 기관을 만들었습니다. 그런 다음이 CA에 서명 한 해당 서비스에 대한 인증서를 작성했습니다. 이제이 CA에서 발급 된 기존 서버 인증서를 무효화하지 않고 루트 CA에 x509 확장 (CRL 배포 지점)을 추가하려고합니다. 이게 가능해? 내가 이해하는 것처럼 해당 개인 키에 대한 액세스가 …

2
Nginx 캐싱 심볼릭 링크
웹 서버에 배포 시스템이 있는데, 앱을 배포 할 때마다 타임 스탬프가 지정된 새로운 디렉토리가 생성되고 새 디렉토리에 "현재"심볼릭 링크가 생성됩니다. 이 모든 것은 아파치에서 훌륭하고 훌륭하게 작동했지만, 내가 설정 한 새로운 nginx 서버에서는 새로운 심볼릭 링크가 아닌 "오래된"배치의 스크립트가 실행되는 것처럼 보입니다. 이 문제를 해결하는 방법에 대한 자습서와 게시물을 읽었지만 …
12 nginx  php-fpm  cache  php7 

1
Api 게이트웨이를 가리 키도록 Route 53을 설정하는 방법
한 번에 웹 사이트를 만드는 Cloudformation 구성 파일을 작성 중입니다. 여기에는 람다 함수 생성, API 게이트웨이 생성, S3 버킷 설정, Route 53 영역 및 레코드 생성이 포함됩니다. 지금까지: Lambda 함수 생성 및 역할 (작동) 배포 및 역할 인 API Gateway 만들기 (작동) S3 버킷 생성 및 정책 (작동) 사이트에 대한 …

2
저장 공간 직접 지침
최근 PoC 목적으로 4x DL380 G7에 WS2016 DC를 배포했습니다. 각 서버에는 4 개의 300GB 10K SAS 드라이브가 있으며 회사에서 일시적으로 빌릴 수있는 몇 개의 인텔 SSD가 있습니다. 저의 주요 목표는 다양한 스토리지 복제본 "모드"를 테스트하고 스토리지 공간 다이렉트 위에 스케일 아웃 파일 서버 역할을 배포하는 것입니다. 약 한 달 전에 …

3
Windows 2012에서 여러 MySQL 인스턴스를 설치하고 시작하는 방법
방금 Windows 2012 VM에 MySQL 5.7을 설치했습니다. 여러 인스턴스를 만들고 실행하려고하지만 그러한 간단한 일이 작동하지 않는다는 것에 매우 좌절했습니다. 기본 위치 인 C : \ Program Files \ MySQL \ MySQL Server 5.7에 MySQL을 설치 한 다음 폴더를 복사하고 다른 인스턴스를 만들기 위해 다른 복사본을 만들었습니다. 두 MySQL 인스턴스는 아래 …

4
Amazon 전용 인스턴스와 전용 호스트의 차이점은 무엇입니까?
Amazon에는 전용 인스턴스와 전용 호스트라는 두 가지 유형의 "전용"인프라가 있습니다. 그들은 말한다 : 전용 호스트에서 인스턴스를 시작하면 해당 인스턴스는 전용 서버에서 실행됩니다. 전용 인스턴스는 전용 하드웨어 에서도 실행되는 반면 전용 호스트는 인스턴스를 특정 물리적 서버 에 배치 할 수 있도록하여 더 많은 가시성과 제어 기능을 제공 합니다 . 이를 통해 …

3
Certbot은 443이 아닌 다른 포트에서 암호화 할 수 있습니다
443이 아닌 다른 포트에서 웹 서버에 대한 certbot을 설정하고 싶습니다. 실행할 때 다음 오류가 발생했습니다. certbot --apache -d <sub>.<domain>.<ext> 인증 절차가 실패했습니다. sub.domain.ext (tls-sni-01) : urn : acme : error : connection :: 서버가 클라이언트에 연결하여 도메인을 확인할 수 없습니다 :: TLS-SNI-01 챌린지에 대해 external_ip : 443에 연결하지 못했습니다 이 …

2
GitLab에서 오래된 백업을 어떻게 삭제합니까?
레이크 작업을 사용하여 GitLab 6.8.2에 대한 백업을 만듭니다. gitlab-rake gitlab:backup:create 에서 /etc/gitlab/gitlab.rb나는 다음과 같은 라인을 추가 : gitlab_rails['backup_keep_time'] = 60 60 초보다 오래된 백업을 정리해야합니다. gitlab:backup:create60 초가 지나면 두 번째 실행으로 첫 번째 백업이 제거 될 것으로 예상했습니다 . 출력의 마지막 줄은 오래된 백업 삭제 중 ... 건너 뛰기 오래된 …
12 backup  git  gitlab 

2
포트 터널링을 사용하여 네트워크 요새를 통해 개인 데이터베이스 인스턴스에 연결하려면 어떻게해야합니까?
에 공개적으로 액세스 할 수있는 네트워크 요새 example.compute-1.amazonaws.com와 개인 postgres 데이터베이스 인스턴스가 있습니다.postgres.example.us-east-1.rds.amazonaws.com:5432 나는 요새를 사용하여 요새에 넣을 수 있습니다. $ ssh -i key.pem ec2-user@example.compute-1.amazonaws.com 그런 다음 요새에 들어가면 ssh 터널을 만듭니다. $ ssh -i key.pem -L 5432:postgres.example.us-east-1.rds.amazonaws.com:5432 ec2-user@example.compute-1.amazonaws.com 그런 다음 localhost를 사용하여 요새에서 데이터베이스에 연결하여 터널이 작동하는지 확인할 수 …

2
액세스 할 수없는 VM
그래서 어젯밤에 에어컨이 우리를 덮 쳤을 때 서버를 원격으로 종료해야했습니다. VM을 종료 한 다음 호스트를 종료했습니다. VM을 자동으로 시작하는 2 개의 호스트를 오늘 시작했습니다. VM의 데이터 저장소는 Synology NAS에 위치한 isci LUN이며 NAS는 종료되지 않았습니다. 어떤 이유로 든 모든 백업을 부팅 할 때 전자 메일 VM이 액세스 할 수없는 것으로 …

4
Webtatic 저장소의 배후는 누구이며 신뢰합니까?
Webtatic 저장소 에는 CentOS 및 RedHat에 유용한 패키지가 많이 있습니다. 그러나 그 저장소는 매우 불투명하며 여기에있는 앤디 톰슨 (Andry Thompson)의 아파트 뒤에있는 정보를 찾기가 어렵다. 그는이 모든 유용한 패키지를 제공하는 훌륭한 일을하고있는 것 같습니다. 라이브 회사 서버에서 리포지토리를 사용해야하고 비공식 리포지토리를 사용하면 즉시 경보가 울립니다. 단일 개인 저장소입니까? 회사에서 지원합니까? …

1
VPN : 오류 : Linux route add 명령이 실패했습니다
VPN 서버를 구성했습니다 local 192.168.0.250 dev tun proto udp port 1194 ca /etc/openvpn/easy-rsa/keys/ca.crt cert /etc/openvpn/easy-rsa/keys/server-vpn.crt key /etc/openvpn/easy-rsa/keys/server-vpn.key dh /etc/openvpn/easy-rsa/keys/dh1024.pem server 10.8.0.0 255.255.255.0 ifconfig 10.8.0.1 10.8.0.2 push "route 10.8.0.1 255.255.255.255" push "route 10.8.0.0 255.255.255.0" push "route 192.168.0.250 255.255.255.0" push "dhcp-option DNS 8.8.8.8" push "redirect-gateway def1" client-to-client duplicate-cn keepalive 10 120 tls-auth …
12 vpn  openvpn 

3
"service nginx start"를 사용하여 Nginx가 정지됨
프로덕션 서버의 사용자 정의 경로로 nginx를 컴파일했으며 다음을 사용하여 서비스를 시작 / 다시 시작하려고합니다. service nginx start 또는 service nginx restart 쉘을 반환하지 않고 새 줄에 들어갑니다. 따라서 문제는 service명령을 사용하여 nginx를 제어 할 수 없다는 것 입니다. 서비스는 실제로 실행되지만 쉘을 반환하지 않으므로 항상 ctrl+ c를 눌러 다시 가져와야합니다. …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.