서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

4
웹 브라우저에서 localhost : 8080으로 이동하면 정확히 어떻게됩니까? (아파치 톰캣)
나는 모든 로컬 응용 프로그램 프로그래밍 (C ++ 응용 프로그램 및 기타)을 수행하면서 경력을 쌓았습니다. 그러나 지금은 발을 웹 세계에 파고 들려고합니다. Eclipse (Mars)와 Apache Tomcat 8.0.23을 사용하여 서버 측 프로그래밍 (JSP, PHP 등)을 실험하고 배울 수있는 환경을 설정하고 시도하고 있습니다. 입력 할 때 모든 것이 설정되었습니다. localhost:8080 내 브라우저에서 …

1
SCCM Powershell 감지 스크립트는 어떤 컨텍스트에서 실행됩니까?
나는 마침내 AllSigned실행 정책을 가진 클라이언트에서 PowerShell 감지 스크립트를 사용하여 성공했습니다 . (힌트 : 최신 서비스 팩 을 설치 하고 Adam Meltzer의 해결 방법을 사용한 후에 작동하기 시작했습니다 .) 이제 응용 프로그램 검색에 PowerShell 스크립트를 사용하는 것이 실용적이기 때문에 다음 사항을 궁금해합니다. SCCM 클라이언트는 어떤 컨텍스트에서 PowerShell 감지 스크립트를 실행합니까? …

3
중국이 Google Compute Engine 서버에 연결하지 못하도록 중지
우리 회사에는 북미에서 호스팅되는 Google Compute Engine 서버가 있습니다. 우리는 많은 중국 IP 주소를 포트 11에 요청을 보내어 수신 비용을 지불합니다. 방화벽은 비즈니스에 응용 프로그램에 액세스 할 수 없으므로 이미 중국에 대한 모든 연결을 차단합니다. 이러한 연결을 완전히 무시하거나 대역폭을 소비하지 않도록 차단할 수있는 방법이 있습니까?

4
서버 측`TIME_WAIT`는 실제로 어떻게 작동합니까?
나는 이것에 대해 몇 가지 SE 질문이 있다는 것을 알고 있으며,이 시점에 오기 전에 중요한 질문을 많이 읽습니다. "서버 측 TIME_WAIT"이란 서버 측에서 close ()가 시작된 서버 측 소켓 쌍의 상태를 의미합니다. 나는 종종 나에게 모순되는 이러한 진술을 본다. 서버 측은 TIME_WAIT무해합니다 클라이언트가 close ()를 시작하도록 클라이언트에 네트워크 응용 프로그램을 …
11 tcp 

2
Linux 가상 머신에서 메모리 핫 제거
Linux는 예를 들어 VMware에서 VM 게스트로 실행될 때 핫 추가 메모리를 지원합니다 . (때로는 게스트 OS 에 수동으로 알려야합니다 .) 역 작업을 수행하는 안전한 방법이 있습니까? 가상 시스템에 할당 된 메모리 양이 줄어 듭니다. 그렇다면 그러한 작업을 수행하기 전에 Linux 게스트에게 수동으로 알려야합니까? (그렇다면 절차는 VMware 도구에만 적용됩니까, 아니면 모든 …

5
Docker-nginx와 php-fpm을 별도로 스케일링
도커 및 도커 작성으로 놀고 있었고 질문이 있습니다. 현재 내 docker-compose.yml은 다음과 같습니다. app: image: myname/php-app volumes: - /var/www environment: <SYMFONY_ENVIRONMENT>: dev web: image: myname/nginx ports: - 80 links: - app volumes_from: - app 응용 프로그램은 포트 9000에 PHP-fpm과 내 응용 프로그램 코드가 포함되어 있습니다. 웹은 몇 비트의 구성으로 nginx입니다. …
11 nginx  php  php-fpm  docker 

3
라우팅 할 수없는 내부 IP 주소가 필요한 링크 로컬 주소를 사용해야합니까?
로드 밸런싱 기능이 포함 된 네트워크 어플라이언스가 있습니다. 내 디자인에서는 이러한 기능이 어플라이언스 내부에서만 사용됩니다. 외부 적으로는 아무 것도 말해서는 안되며, 추가적으로 클라이언트는 장치 IP 범위의 IP 주소가 적습니다. 이러한 기능에 링크 로컬 범위를 사용할 수 있습니까? 예를 들면 다음과 같습니다 169.254.1.1. 주의 : 해당 장치는 이러한 기능에 루프백 IP를 …
11 networking 

3
프록시를 통해 전달 된 모든 페이지의 내용을 URL에 대해 mod_rewrite를 사용하는 것과 비슷한 방식으로 바꿀 수 있습니까?
프록시를 통해 전달 된 모든 페이지의 내용을 URL에 대해 mod_rewrite를 사용하는 것과 비슷한 방식으로 바꿀 수 있습니까? 대체 문서는 명확하지 않습니다. 절대 경로가있는 리버스 프록시 페이지가 있습니다. 사이트가 손상됩니다. 그것들은 교체해야하며 mod_rewrite와 같은 도구는 URL 요청이 아니기 때문에 선택하지 않습니다. <VirtualHost *:80> ServerName servername1 ServerAlias servername2 ErrorLog "/var/log/proxy/jpuat_prox_error_log" CustomLog "/var/log/proxy/jpuat_prox_access_log" …

2
여러 도커 컨테이너에 대한 IAM 보안 자격 증명 관리
일반 EC2 환경에서 다른 AWS 리소스에 대한 액세스 관리는 IAM 역할 및 자격 증명 (인스턴스 메타 데이터에서 자동으로 가져 오기)을 통해 매우 간단합니다. CloudFormation을 사용하면 인스턴스에 특정 애플리케이션 역할을 할당 할 때 즉시 역할을 생성 할 수 있습니다. Docker로 마이그레이션하고 M 머신과 N 애플리케이션이 실행되는 M-to-N 배포를 원하는 경우 애플리케이션 …

2
300Mbit (14 %)에서 극단적 인 UDP 패킷 손실, 재전송없이 TCP> 800Mbit
iperf3클라이언트 로 사용하는 Linux 상자가 있으며 Broadcom BCM5721, 1Gb 어댑터 (2 포트, 테스트에 1 개만 사용됨)를 사용하여 동일하게 설치된 Windows 2012 R2 서버 상자 2 개를 테스트합니다. 모든 머신은 단일 1Gb 스위치를 통해 연결됩니다. 300Mbit에서 UDP 테스트 iperf3 -uZVc 192.168.30.161 -b300m -t5 --get-server-output -l8192 전송 된 모든 패킷의 14 %가 …

1
위치 내의 nginx if 문이 404를 반환 함
다음 블록 location / { if ($http_origin ~* (https?://[^/]*\.example\.com(:[0-9]+)?)) { add_header 'Access-Control-Allow-Origin' "$http_origin"; } try_files $uri $uri/ /index.php?$args; } … 위 코드가 try_files지시문에 도달하지 않으므로 404가 발생합니다 . 이것은 nginx 의 IfIsEvil 과 관련이 있습니까? 그렇다면 http_originif 문을 사용하지 않고 테스트하는 다른 방법이 있습니까? 나는 nginx> 1.4 (1.4.6, 1.7, 1.7.8)로 …
11 nginx  cors 

1
jenkins가 git 저장소에 연결하지 못함
Jenkins가 액세스 할 수있는 방식으로 자식 저장소 URL을 구성 할 수 없습니다. "프로젝트> 구성> 소스 코드 관리"에서 저장소 URL을 "git @ store : repositories / testproject.git"로 설정했습니다. 이 오류가 발생합니다. Failed to connect to repository : Command "/usr/bin/git -c core.askpass=true ls-remote -h git@store:repositories/testproject.git HEAD" returned status code 128: stdout: stderr: …
11 git  jenkins 

2
IPSec 터널을 통한 10Mbps로 제한된 20Mbps WAN
최근 10 / 10Mbps 파이버에서 20 / 20Mbps 파이버 링크로 원격 사이트를 업그레이드했습니다 (지하실에서 파이버, 지하실에서 사무실까지의 VDSL, 약 30 미터). 이 사이트와 중앙 사이트간에 정기적으로 큰 (멀티 기가) 파일 사본이 있으므로 이론상 20/20으로 링크를 늘리면 전송 시간이 대략 절반으로 줄어 듭니다. 파일 복사 전송 (예 : robocopy어느 한 방향으로 …

2
RHEL7에서 방화벽으로 저장하여 실행하는 방법이 있습니까?
RHEL7을 사용하기 시작했고 systemd와 함께 제공되는 변경 사항에 대해 조금 배우고 있습니다. /sbin/service iptables save방화벽 으로 수행 할 수있는 방법이 있습니까? $ /sbin/service iptables save The service command supports only basic LSB actions (start, stop, restart, try-restart, reload, force-reload, status). For other actions, please try to use systemctl. 설명서에서 찾을 …

2
Docker 데몬은 업데이트 후 '404 페이지를 찾을 수 없습니다'라고 대답합니다.
최근에 도커를 1.4에서 1.5 (패키지 포함 lxc_docker)로 업데이트했습니다. 그 후 docker 데몬은 다음과 같은 오류를 보냅니다 (모든 명령에 대해). $ docker version Client version: 1.5.0 Client API version: 1.17 Go version (client): go1.4.1 Git commit (client): a8a31ef OS/Arch (client): linux/amd64 FATA[0000] Error response from daemon: 404 page not found 그러나 …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.