서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
HAProxy, 호스트 이름이 다른 여러 서버의 상태 점검
호스트 이름이 다른 여러 실행 서버간에로드 균형을 조정해야합니다. 각각에 동일한 가상 호스트를 설정할 수 없습니다. 여러 서버로 하나의 청취 구성 만 가질 수 있고 상태 점검이 http-send-name-header Host지시문을 적용하도록 할 수 있습니까? HAProxy 1.5를 사용하고 있습니다. 이 작업 haproxy.cfg를 생각해 냈습니다. 보시다시피 상태 확인이를 무시할 때 각 상태 확인마다 다른 …
11 haproxy 

1
원래 요청 된 리소스의 절대 주소를 포함하는 사용자 지정 헤더를 추가하는 방법
다음과 같은 설정이 있습니다. |-------|--- backend1:8080 example.com:80---|HAProxy|--- backend2:8080 |-------|--- backend3:8080 원래 URL을 포함하는 사용자 정의 헤더를 추가하도록 HAProxy를 구성하고 싶습니다. 예를 들어 사용자가을 요청하는 경우 http://example.com/foo?bar=baz: GET /foo?bar=baz HTTP/1.1 Host: example.com:80 HAProxy가이 요청을 다음과 같이 백엔드로 변환하고 싶습니다. GET /foo?bar=baz HTTP/1.1 Host: backend1:8080 x-custom-header: http://example.com/foo?bar=baz 이 reqadd옵션을 사용하면 정적 값으로 …
11 haproxy 

2
IIS에서 사용하지 않는 응용 프로그램 풀이 성능에 영향을 줍니까?
아키텍처의 주요 업데이트로 인해 이제 IIS에서 사용되지 않는 응용 프로그램 풀이 몇 개 있습니다 (웹 사이트에는 매핑되지 않음). 가독성을 높이기 위해 제거하는 것이 좋은 생각이지만 내 질문은 성능에 미치는 영향에 관한 것입니다.이 사용되지 않는 응용 프로그램 풀을 갖는 것이 메모리, CPU, IIS 요청 처리 속도 또는 기타 성능 메트릭 측면에서 …

1
SSL 인증서를 거부하는 브라우저 수를 확인하십시오.
웹 서버에 HTTP 요청을 할 때 SSL 인증서를 거부하는 브라우저 수를 확인하고 싶습니다. 우리는 현재 대부분의 최신 브라우저에서 인식하는 것처럼 보이는 무료 CA를 사용하고 있지만 브라우저와 운영 체제의 조합을 철저하게 테스트하지 않고도 숫자를 얻고 싶습니다. 인증서 확인에 실패하면 브라우저가 연결을 종료한다는 것을 알고 Apache가이를 감지 할 수있는 방법이 있습니까? 구체적인 …

1
데비안에서 시작 스크립트를 실행하려고 할 때 그러한 파일이나 디렉토리 오류가 없습니다
데비안 (Raspbian)을 처음 접했고 며칠 동안이 문제를 해결하려고 애 쓰고 있습니다. 시작할 때 실행할 시작 스크립트가 있습니다. 스크립트를 실행 가능하게 만들고 기본 매개 변수를 사용하여 시작 순서에 추가하기 위해 다음 명령을 실행했습니다. sudo chmod 755 /etc/init.d/testsam sudo update-rc.d testsam defaults 스크립트를 테스트하려고 할 때 다음을 실행합니다. sudo /etc/init.d/testsam start 그러나 …

3
RAID 컨트롤러를 4kn로 업그레이드-4kn을 사용하려면 어레이를 다시 초기화해야합니까?
Adaptec 6405E RAID 컨트롤러 가있는 엔터프라이즈 급 워크 스테이션이 있습니다. Adaptec에 따르면이 RAID 컨트롤러는 기본적으로 4K 디스크 섹터를 지원하지 않으며 지원할 수 없습니다. 4K 디스크를 넣은 경우 512 바이트 섹터 에뮬레이션 모드 (512e)가 있으면 512e를 사용합니다. 512e가 없으면 디스크가 전혀 작동하지 않습니다. 내 6405E에는 4K 기본 섹터를 가진 4 개의 …

1
rsync : getcwd () : 해당 파일 또는 디렉토리 없음 (2)
Server1와 Server2로그를 동기화 하고 싶습니다 LogServer. 의 경우 Server1: rsync -avz -e 'ssh -p 2188' user@server1:/usr/local/servers/logs/* /usr/local/logs/ 이것은 작동하지만 Server2: rsync -avz -e 'ssh -p 2188' user@server2:/usr/local/servers/logs/* /usr/local/logs/ 실패합니다 : shell-init: error retrieving current directory: getcwd: cannot access parent directories: no such file or directory job-working-directory: error retrieving current directory: …
11 linux  ssh  rsync  shell 

2
'대형'레이드 5 어레이는 무엇입니까?
사무실에있는 Buffalo TeraStation NAS의 최근 문제로 인해 Raid 5를 조사했습니다. 대형 어레이 또는 대형 디스크에서 RAID 5를 사용하는 것이 부적합하다는 것에 대한 몇 가지 다른 기사를 발견했습니다. 다음은 대형 소비자 드라이브가있는 어레이를 재구성 할 때 발생하는 문제에 대해 설명 하는 기사의 예 입니다. '큰 것'으로 간주되는 것을 해결하려고합니까? 여기에있는 NAS는 …
11 raid  raid5 

1
Netstat 중단 : 왜?
"netstat"를 입력 할 때 가끔 (아주 자주는 아님) 돌아 오는 데 5 초가 걸립니다. 다른 시간은 순간적입니다. 내 서버 (CentOS 6.4)에서 몇 주 동안 이것을 관찰했지만 그 이유를 이해할 수 없습니다!? 누구든지 설명 할 수 있습니까?

3
현재 ssh dsa 호스트 키에 필요한 것은 무엇입니까?
* nix 서버를 다루기 시작했을 때, openssh 서버는 rsa 호스트 키뿐만 아니라 dsa와 함께 제공되었으며, openssh 클라이언트는 rsa 키를 선호합니다. 오늘날 openssh 서버에는 dsa, rsa 및 ecdsa 호스트 키가 있으며 openssh 클라이언트는 ecdsa 호스트 키를 선호합니다. dsa 호스트 키를 제공하도록 openssh를 구성하려면 어느 정도까지 필요합니까? 비 openssh 클라이언트 구현과 관련하여 …
11 ssh 

1
많은 파티션을 활용하기 위해 ZFS 풀 또는 LVM 볼륨 그룹이 더 안정적입니까?
새 파일 서버를 구성 할 때 LVM 볼륨 그룹 또는 ZFS 풀을 사용할지 여부를 결정할 때 고려해야 할 사항은 무엇입니까? 다목적 파일 서버 영역에서 "더 나은"선택이 있습니까? 이 이전 질문 과 달리 기술을 계층화하고 싶지 않습니다. 대본: RHEL / CentOS 6 x64 서버 사용 가능한 동일한 DAS 및 SAN LUN …
11 linux  lvm  partition  zfs 

2
Chef : 알림만으로 리소스를 실행하는 방법은 무엇입니까?
알림과 알림에서만 여러 번 실행하려는 리소스를 선언하고 싶습니다. 리소스가 선언 된 후 리소스가 스스로 실행되지 않도록하려면 어떻게해야합니까? 알림이 있는지 확인하는 방법이 있습니까? "only_if : notified"와 같은 것을 실행할 수 있습니까?
11 chef 

1
Windows Server 2008 R2에서 IIS 7.5를 통해 CSR을 생성하면 항상 새 개인 키가 생성됩니까?
Windows 2008 R2 서버에 대한 CSR을 생성하고 CSR에 사용 된 개인 키가 새 것인지 확인해야합니다. 테스트를 위해 자체 서명 인증서를 작성하기 전에 OpenSSL을 사용해 왔으며 올바르게 기억하는 경우 사용할 개인 키를 지정할 수있었습니다. IIS 서버 인증서에서 개인 키를 생성하거나 선택하라는 메시지가 표시되지 않습니다. 그렇다면 Windows 기반 서버에서 CSR을 생성하면 항상 …

1
SSH-RSA 공개 키의 User @ host
공개 ssh-rsa 키 재생이 끝날 때 종종 나타나는 user @ host의 역할은 무엇입니까? 그게 필요 할까? 인증에 어떤 목적을 제공 하는가, 아니면 단순히 정보를 목적으로 (인간 독자를 위해) 키가 누구와 어디서 생성되었는지에 대한 기록입니까?

3
NetApp 스냅 샷을 백업으로 사용할 수 있습니까?
우리 상점은 백업을 위해 NetApp Volume Snapshots에 크게 의존합니다. 우리는 일부 데이터에 대해 전통적인 에이전트 기반 테이프 백업을 사용 하지만 대체로 대부분의 시스템에 대한 스냅 샷에 의존합니다. 또한 우리는 너무 엄격한 변경 관리 정책이나 중앙 구성 관리를하지 않아도 모든서비스 제공 데이터의 백업 여부에 관계없이 당사의 서버 중 일부는 베어 메탈 …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.