서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

1
언제 Etags를 사용해야합니까?
방금 WebPageTest.org 사이트를보고 있었고 웹 사이트 속도를 높이기위한 권장 사항 중 하나는 다음과 같습니다. ETag 헤더는 특별한 이유가없는 한 일반적으로 사용하지 않아야합니다. 이것이 무엇을 의미하는지 궁금했습니다. 그것은 당신이 그들을하지 말았어야 변경되지 않습니다 알고 정적 컨텐츠를 의미하거나, 당신이 그들을 필요는 없습니다 정기적으로 변경됩니다 알고 평균 함량을한다, 또는 당신이 그들을 사용하지 않도록 …

2
ifconfig 출력에서 ​​RX 'errors'및 'frame'의 정확한 의미는 무엇입니까?
(RHEL) 노드 (패킷 삭제)의 네트워크 문제가 있는데 ifconfig 출력에서 ​​'error'및 'frame'필드가 0이 아닌 숫자로 나타납니다. eth2 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx ... RX packets:277593775 errors:1049 dropped:0 overruns:0 frame:536 '오류'와 '프레임'의 정확한 의미가 어딘가에 대한 자세한 설명이 있습니까? 편집 : 출력 ethtool eth2: Settings for eth2: Supported ports: [ TP ] Supported …

3
FTP 및 Apache 권한 문제
어떤 사용자가 내 www 디렉토리 (ftp 또는 apache)를 소유해야하는지에 대한 문제가 있습니까? ftp 사용자로 설정하면 사용자는 파일을 추가, remoe 및 쉽게 수정할 수 있지만 php 파일 시스템 조치는 권한 거부 오류를 생성합니다 (물론 사용자가 아파치 여야 함). 그러나, www 디렉토리가 아파치 될 경우, ftpuser는 파일 수정 및 삭제와 같은 일부 …

5
신뢰할 수없는 느린 WAN을 통한 ZFS 동기화 ZFS 복제 또는 rsync?
WAN을 통한 오프 사이트 백업 작업을 맡았습니다. 두 스토리지 박스 모두 ZFS를 실행하는 FreeBSD 기반 NAS 박스입니다. 일주일에 한두 번, 15-60 기가의 사진 데이터가 사무실 NAS에 덤프됩니다. 저의 임무는 VERY SLOW DSL 연결 (~ 700Kb / s 업로드)을 사용하여이 데이터를 사이트 외부에서 최대한 안정적으로 얻는 방법을 알아내는 것입니다. 수신 박스의 …

3
공유 호스팅 환경 (예 : Dreamhost)에서 mod_rails 및 Apache를 사용하여 Gollum을 실행하는 방법은 무엇입니까?
Gollum 은 GitHub의 새로운 위키 엔진으로 Ruby로 작성되었습니다. 로컬로 배포되어 Sinatra 인스턴스를 사용하여 웹 인터페이스를 제공합니다. Apache 및 mod_rails (Phusion Passenger)를 사용하여 Dreamhost와 같은 공유 호스팅 환경에서 실행할 수 있습니까?

1
많은 행을 삭제 한 후 테이블을 REINDEX하고 VACUUM해야합니까?
로깅 정보를 저장하는 여러 테이블이있는 PostgreSQL 데이터베이스를 실행 중입니다. 이 정보는보고 목적으로 만 사용되며 파일로 덤프되어 30 일이 지난 경우 데이터베이스에서 삭제됩니다. 수백만 개의 행이 삭제 될 수 있으며 삭제 후마다 REINDEX를 실행하고 있습니다. 이것으로 충분합니까, 아니면 VACUUM 또는 VACUUM ANALYZE도 실행해야합니까? 또는 REINDEX 필요가 없습니다 우리는 대신한다 단지 진공 …

9
centos에서 NIC를 비활성화하는 방법
다음과 같은 스크립트에 대한 '한 줄짜리'를 찾고 있습니다. eth0을 비활성화하십시오. 부팅시 시작되지 않도록하십시오. IP 주소를 빼앗아 이 주소를 다시 사용하지 않도록하십시오.

2
apache2 : 등록 된 핸들러 목록 가져 오기
아파치에서 모든 핸들러 목록을 얻는 것이 가능합니까? 로 setHandler 이 핸들러를 만들 수 있습니다. 한 가지 가능한 사용법은 특정 파일 확장자 ( addHandler ) 에 대한 핸들러를 추가하는 것 입니다. 가능한 모든 핸들러와 해당 식별자를 알면 파일 확장자와 일치하는 프로세스가 쉬워집니다 (또는 URL 핸들러가 가능한 URL 목록을 작성하는 경우). 핸들러는 …

1
Django / Apache / mod_wsgi 사이트에서 높은 CPU로드
Apache 벤치를 사용하여 AWS 소형 인스턴스 (Ubuntu 10.04)에서 django 1.21 / Apache / mod_wsgi 구성을로드 테스트하면 낮은 동시 요청에서 매우 높은 CPU로드 (업타임 및 vmstat 사용)가 표시됩니다. ab -c 5 -n 1000 "my_url" ...이 가동 시간 출력을 유발합니다. 18:04:54 up 9 days, 16:54, 3 users, load average: 5.33, 2.45, 1.91 …




7
초 고밀도 PC / 랙 필요
나는 서버 녀석, 특히 블레이드 녀석이며 내 고급 장비를 잘 알고 있지만 조금 잃어버린 새로운 작은 도전에 직면하여 도움을 줄 수 있습니다. 특정 작업을 수행 할 서버 사양이 있으며 가상화를 보았고 둔한 이유로 작동하지 않을 것입니다 (아직도 아닙니다). 기계는 가지고 있어야합니다. 듀얼 코어 소비자 프로세서 매우 낮은 전력 / 열 …
10 desktop 

7
내 환경에 VLAN이 필요합니까?
저는 학교의 새로운 네트워크 관리자입니다. 여러 Windows 서버, 약 100 개의 Windows 클라이언트, 10 개의 프린터, 1 개의 Cisco 라우터, 6 개의 Cisco 스위치 및 1 개의 HP 스위치로 구성된 환경을 상속했습니다. 또한 VoIP를 사용하고 있습니다. 우리 건물에는 4 층이 있습니다. 각 층의 호스트는 별도의 VLAN에 할당됩니다. 1 층 사무실에는 …

2
아파치 리디렉션 및 캐시 헤더 설정?
Apache에서 리디렉션을 수행하는 것은 쉽습니다 (mod_alias). RedirectMatch ^.*$ http://portal.example.com/ 캐시 헤더를 설정하는 것도 마찬가지로 쉽습니다. Header set Cache-Control max-age=0 Header set Expires "Thu, 01 Dec 1994 16:00:00 GMT" (캐시를 원하지 않습니다) 그러나! 둘을 결합 할 수없는 것 같습니다. 이 구성으로 인해 리디렉션이 전송되지만 헤더는 전송되지 않습니다. <VirtualHost *:80> ServerName __default__ …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.