서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
EC2 보안 그룹 변경이 인스턴스 실행에 즉시 적용됩니까?
EC2 인스턴스가 실행 중이며 보안 그룹에 속합니다. AWS Management Console을 통해 해당 보안 그룹에 새로운 허용 된 연결을 추가하면 해당 변경 사항이 즉시 적용 됩니까? 아니면 인스턴스를 다시 시작한 후에 만 ​​가능합니까? 필자의 경우 PostgreSQL의 기본 포트 (tcp 5432 5432 0.0.0.0/0)에 대한 액세스를 허용하려고하는데 연결을 거부하는 EC2 방화벽 또는 PostgreSQL의 …

7
프로세스가 대화식으로 수행되는 것보다 예약 된 작업으로 느리게 실행
CPU 및 IO를 많이 사용하는 예약 된 작업이 있으며 실행하는 데 약 4 시간이 걸립니다 (호기심이있는 경우 소스 코드 작성). 이 작업은 다양한 하위 프로세스를 생성하여 작업을 수행하는 Powershell 스크립트입니다. 동일한 사용자 계정으로 Powershell 프롬프트에서 동일한 프로세스를 대화식으로 실행하면 약 2 시간 30 분 안에 실행됩니다. 작업이 Windows Server 2008 …

11
재부팅하지 않고 핫 스왑 된 새 SATA / dev / sda 드라이브를 Linux가 인식하도록하려면 어떻게합니까?
실패한 SATA / dev / sda 드라이브의 핫 스왑은 정상적으로 작동했지만 새 드라이브로 스왑 할 때 인식되지 않았습니다. [root@fs-2 ~]# tail -18 /var/log/messages May 5 16:54:35 fs-2 kernel: ata1: exception Emask 0x10 SAct 0x0 SErr 0x50000 action 0xe frozen May 5 16:54:35 fs-2 kernel: ata1: SError: { PHYRdyChg CommWake } …

4
Route 53은 길이가 너무 길어 DKIM 키 추가를 허용하지 않습니다.
다음은 DKIM 키 값을 입력하는 방법입니다. "v=DKIM1; k=rsa; p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAwztXzIUqic95qSESmnqX U5v4W4ENbciFWyBkymsmmSNOhLlEtzp/mnyhf50ApwCTGLK9U7goo/ijX/wr5roy XhReVrvcqtIo3+63a1Et58C1J2o4xCvp0K2/lM6hla4B9jSph7QzjYdtWlOJqLRs o0nzcut7DSq/xYcVqvrFDNbutCfG//0wcRVUtGEyLX/a/7mAAkW6H8UEYMPglQ9c eEDfTT6pzIlqaK9cHGOsSCg4r0N8YxnHFMRzKaZwmudaXTorSbCs7e681g125/vJ e82VV7DE0uvKW/jquZYtgMn7+0rm+2FDYcDx/7lzoByl91rx37MAJaUx/2JHi1EA nwIDAQAB" 이 값에는 새로운 줄이 없습니다 (특히 텍스트 편집기에서 붙여 넣은 후 복사했습니다). 그러나 어떤 이유로 TXT가 너무 오래 걸리는 오류가 계속 발생합니다. TXTRDATATooLong는 V = DKIM1 "에서 발생; K = RSA; p = MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAwztXzIUqic95qSESmnqX U5v4W4ENbciFWyBkymsmmSNOhLlEtzp …

3
누락 된 시스템 장치를 제거하는 방법?
더 이상 파일이없는 시스템 장치를 제거하는 방법을 알아내는 데 문제가 있습니다. 그들은 여전히 ​​시스템에 남아있는 것처럼 보입니다. 내가 제거하려고하는 오래된 깨진 단위 : core@ip-172-16-32-83 ~ $ systemctl list-units --all firehose-router* UNIT LOAD ACTIVE SUB DESCRIPTION <E2><97><8F> firehose-router@02.service not-found failed failed firehose-router@02.service <E2><97><8F> firehose-router@03.service not-found failed failed firehose-router@03.service LOAD = Reflects …
40 systemd  coreos 

2
업스트림 SSL을 사용하여 Nginx를 리버스 프록시로 구성
클라이언트에서받은 https 요청이 https를 통해 업스트림 서버로 전달되도록 Nginx 서버를 리버스 프록시로 구성하려고합니다. 내가 사용하는 구성은 다음과 같습니다. http { # enable reverse proxy proxy_redirect off; proxy_set_header Host $http_host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwared-For $proxy_add_x_forwarded_for; upstream streaming_example_com { server WEBSERVER_IP:443; } server { listen 443 default ssl; server_name streaming.example.com; access_log …

10
Linux DNS 서버에서 바이러스 백신 소프트웨어를 실행하십시오. 말이 되나요?
최근 감사 기간 동안 Linux (bind9)를 실행하는 DNS 서버에 바이러스 백신 소프트웨어를 설치해야했습니다. 침투 테스트 중에 서버가 손상되지 않았지만 이는 권장 사항 중 하나였습니다. 일반적으로 Linux 안티 바이러스 소프트웨어는 사용자에게 전송되는 트래픽을 스캔하기 위해 설치되므로 dns 서버에 안티 바이러스를 설치하는 목표는 무엇입니까? 제안에 대한 귀하의 의견은 무엇입니까? 실제로 Linux 서버에서 …


5
pkcs12 컨테이너에서 개인 키 비밀번호를 제거하는 방법?
Chrome의 SSL / export 명령을 사용하여 인증서를 추출했습니다. 그런 다음 openvpn의 구성에서 openvpn에 대한 입력으로 제공하십시오. pkcs12 "path/to/pkcs12_container" 전화를 openvpn ~/openvp_config할 때 개인 키의 암호를 묻습니다 (Chrome을 사용하여 내보낼 때 입력 한 암호). Enter Private Key Password:... 이 비밀번호 요청을 삭제하고 싶습니다. 질문 : pkcs12에서 개인 키의 암호를 제거하는 방법은 …

7
Active Directory 사용자가 원격 데스크톱을 사용하도록 허용하는 방법
Active Directory를 설정하거나 사용하는 것은 이번이 처음입니다. 그것을 설정하고 컴퓨터 (실제로 Hyper V의 VM)를 활성 디렉토리에 추가하고 hyper-V를 사용하여 VM에 연결하면 활성 디렉토리 도메인의 사용자를 사용하여 로그인 할 수 있습니다 VM. 그러나 원격 데스크톱을 통해 로그인하려고하면 다음 오류가 발생합니다. The connection was denied because the user account is not authorized …

3
AD 도메인 컨트롤러에 대한 DNS 서버의 순서는 무엇이며 왜됩니까?
이것은 Active Directory DNS 설정에 대한 정식 질문 입니다. 관련 : Active Directory 도메인 서비스 란 무엇이며 어떻게 작동합니까? 여러 도메인 컨트롤러가있는 환경을 가정합니다 (모두 DNS를 실행한다고 가정). DNS 서버는 각 도메인 컨트롤러의 네트워크 어댑터에 어떤 순서로 나열되어야합니까? 각 도메인 컨트롤러의 기본 DNS 서버로 127.0.0.1을 사용해야합니까? 어떤 버전이 영향을 받는지 …

4
매일 로그 로테이션?
logrotate 구성이 "size"및 "daily"매개 변수로 지정된 경우 어느 것이 우선합니까? 이것은 어디에 문서화되어 있습니까? 이러한 회전이 부울 OR 연산으로 발생하기를 원합니다. 즉, 로그가 하루가 지나면 회전되거나 특정 크기보다 크면 회전됩니다. 그러나 logrotate는 현재 "size"지시문 만 사용하며 "daily"지시문을 무시하는 것으로 보입니다. Logrotate는 1 시간마다 실행되도록 설정되어 있습니다. OS는 Linux, Red Hat …
40 logrotate 


9
루트로 작동하는 여러 Linux sysadmin
우리 팀에는 몇 개의 데비안 서버를 관리해야하는 노련한 Linux 시스템 관리자가 있습니다. 이전에는 SSH 공개 키 인증을 사용하여 루트로 작업했습니다. 그러나 우리는 해당 시나리오에 대한 모범 사례가 무엇인지에 대해 토론했으며 아무것도 동의하지 않았습니다. 모든 사람의 SSH 공개 키는 ~ root / .ssh / authorized_keys2에 있습니다. 장점 : 사용하기 쉽고 SSH …
40 linux  root 

4
DNS는 왜 그렇게 작동합니까?
이것은 DNS (Domain Name Service)에 대한 정식 질문 입니다. DNS 시스템에 대한 이해가 정확하면 .com 레지스트리에 도메인 (www.example.com)을 DNS 서버에 매핑하는 테이블이 있습니다. 장점은 무엇입니까? 왜 IP 주소에 직접 매핑하지 않습니까? 다른 IP 주소를 가리 키도록 DNS 서버를 구성 할 때 변경해야하는 유일한 레코드가 DNS 서버에있는 경우 프로세스가 즉각적이지 않은 …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.