서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

4
Python 스크립트가 수정 될 때 uWSGI를 다시 시작하려면 어떻게해야합니까?
위치를 기억할 수는 없지만 프로젝트 스크립트가 수정되면 uWSGI가 Django 개발 서버처럼 다시로드 될 수 있다고 읽었습니다. 나는 문서 나 인터넷 에서 그것을 찾을 수 없습니다 . 어떻게해야합니까? 작업 시스템에서 Ubuntu 12.04를 사용하고 무대 및 프로덕션 서버에서 Dbiano 1.4 및 uWSGI 1.2에서 Debian Squeeze를 사용합니다.
38 django  uwsgi 

5
디렉토리에 대한 액세스를 허용하지만 Apache“서버 구성에 의해 클라이언트가 거부되었습니다”(vhost 구성)
Ubuntu의 Apache에서는 가상 호스트를 설정했지만 브라우저에서 "403 액세스 금지"오류가 계속 발생합니다. 로그에 " 서버 구성에 의해 클라이언트가 거부되었습니다 : / home / remix / ". 온라인 솔루션을 찾고 디렉토리 액세스에 대한 많은 게시물 (모두 허용 등)을 찾았지만 이미 알고있는 한 이미 그랬습니다. 에서 아파치 - vhosts.conf 다음과 같은 코드가있다 : …

4
IIS 7 applicationHost.config 구성 파일을 직접 편집
IIS 7+는 이제 메타베이스 대신 XML 구성 파일을 사용한다는 것을 알고 있습니다. 또한 특정 사이트에 대한 web.config 파일을 편집하면 IIS가 자동으로 변경 사항을 감지하고 해당 구성 변경 사항을 구현합니다. 그러나 이것은 서버 레벨 applicationHost.config 설정 파일에도 적용됩니까? (일반적으로 C : \ windows \ system32 \ inetsrv \ config에 있습니다.) 특히 …


7
lost + found를 삭제하면 어떻게됩니까
ext3과 같은 일부 Linux 파일 시스템을 만들면 'lost + found'디렉토리가 생성됩니다. 이 파일 에 따르면 어떤 종류의 시스템 충돌로 인해 파일이 손상된 경우 거기에 배치됩니다. 이 디렉토리가 제거되고 시스템이 충돌하면 어떻게됩니까? 폴더가 제거되면 mkdir lost + found 로 새 디렉토리를 만들 거나 파일 시스템을 만들 때만 설정할 수있는 속성이 있습니다.


6
fail2ban을 사용하여 n 번 재 시도한 후 영구적 인 IP 차단
아래와 같이 fail2ban을 구성했습니다. 3 번의 시도 실패 후 IP 차단 300 초 타임 아웃 후 IP 해제 이것은 완벽하게 작동하며 유효한 사용자가 시간 초과 후 로그인을 다시 시도 할 수있는 방식으로 유지하고 싶습니다. 이제 동일한 IP가 공격으로 탐지되어 차단 된 경우 5 회 차단 해제하고 IP를 영구적으로 차단하고 다시 …
38 fail2ban 

6
Windows 7 용 무료 NFS 클라이언트가 있습니까?
Windows 7 Professional이 있지만 Windows 용 NFS 클라이언트는 Enterprise 및 Ultimate 버전에만 포함되어 있습니다. 현재 사용중인 Samba 서버를 제거 할 수 있도록 일부 Windows 시스템을 NFS 서버에 연결하고 싶습니다. Windows 7 용 무료 NFS 클라이언트가 있습니까? ProNFS 및 axeNFS와 같은 도구가 있지만 무료가 아닙니다.
38 windows-7  nfs 

4
NLA를 활성화 한 후 RDP 오류 "요청한 기능이 지원되지 않습니다"
NTLMv2뿐만 아니라 네트워크 수준 인증 사용과 같은 서버 중 하나에 RDP를 시도하고 있습니다. 이것은 업데이트를 위해 서버를 재부팅해야 할 때까지 잘 작동했습니다. 이제 더 이상 서버에 RDP를 설치할 수 없습니다. RDP를 통해 연결하려고하면이 오류가 발생합니다. 인증 오류가 발생했습니다-요청한 기능이 지원되지 않습니다 인증 오류가 발생했습니다. 요청한 기능이 지원되지 않습니다 http://funeasytech.com/rdp-connection-error-of-the-requested-security-package-does-not- 와 …

2
1GB 미만 만 사용하는 경우 4TB의 스토리지에 대한 AWS S3 충전
대규모 S3 청구서를 이해하는 데 어려움을 겪고 있으며 AWS 월별 지원에 30 달러를 버리기 전에 여기에 물어볼 것입니다. 기본적으로 다른 암호 화폐 거래소에 API를 만들고 인스턴스 HD에 대한 응답을 저장 하는 Amazon EC2 인스턴스가 있습니다. 약 5 분마다 호출이 이루어지고 응답 객체는 약 100kb이며 R 스크립트 가 읽고 8 분마다 …

2
RAID에서 SSD 모델을 혼합 할 때 어떤 위험이 있습니까?
한 가지 유형의 디스크 병목 현상을 제외하고 RAID에서 SSD 모델을 혼합하는 데 다른 문제가 있습니까? 내 문제는 RAID10에서 4 배의 Samsung 845DC EVO 960GB가있는 서버의 스토리지를 업그레이드해야한다는 것입니다. 이 드라이브는 더 이상 사용할 수 없으므로 필 요한 옵션은 최신의 SSD를 사용하거나 어레이를 모두 교체하는 것입니다.
37 raid  hardware  ssd 

3
fsck는 언제 위험한가요?
최근에 일관성 문제로 인해 원격 데이터 센터에있는 시스템의 루트 파일 시스템이 읽기 전용으로 다시 마운트되는 것을 보았습니다. 재부팅시이 오류가 표시되었습니다. UNEXPECTED INCONSISTENCY: RUN fsck MANUALLY (i.e., without -a or -p options) 제안한대로 fsck를 실행하고로 수정 사항을 수동으로 수락 Y하면 오류가 수정되고 이제 시스템이 정상입니다. 이제는 fsck가 모든 것을 자동으로 실행하고 …

1
위치의 nginx 설정 변수
nginx 구성을 최적화하려고하므로 하나의 변수를 설정할 수 있으며 모든 위치 경로가 자동으로 업데이트됩니다. 질문에 네 줄이 있습니다. server_name php.domain.com; root /srv/web/vhosts/php/web; error_log /srv/web/vhosts/php/logs/error.log; access_log /srv/web/vhosts/php/logs/access.log; 내가 달성하고자하는 것은 하나의 변수 (이 경우 'php')를 설정하고 구성에 포함시키는 것입니다. set $variable "php"; server_name $variable.domain.com; root /srv/web/vhosts/$variable/web; error_log /srv/web/vhosts/$variable/logs/error.log; access_log /srv/web/vhosts/$variable/logs/access.log; 그러나 nginx …
37 nginx 

5
TTL을 24 시간에서 5 분으로 변경했습니다. 기록을 변경하기 전에 24 시간을 기다려야합니까?
Rackspace ta 전용 서버의 클라우드 서버에서 앱을 마이그레이션하고 있습니다. 클라우드 서버에서 전용 서버로 데이터를 복사하기 위해 응용 프로그램을 약 5 분 동안 중단하고 싶습니다. 따라서 데이터를 복사 한 후 이전 서버로 요청을 보내고 싶지 않습니다. 새 서버에서 DNS 레코드를 가리키고 싶지만 TTL이 24 시간으로 설정되었습니다. 나는 그것을 300 초로 변경했습니다. …

3
예비 전원 공급 장치가있는 서버는 어떻게 균형을 유지합니까?
HP DL360 라인 (5-8 세대)의 서버가 여러 대 있습니다. 이러한 각 서버에는 두 개의 전원 공급 장치가 설치되어 있습니다. 각 서버의 2 개의 전원 공급 장치는 서로 다른 회로에서 공급됩니다. 내 질문은 전력 소비가이 두 회로 사이에서 대략 균형을 잡을 것인가 아니면 서버가 한 전원 공급 장치를 "기본"으로 간주하고 다른 …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.