서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

8
SQL Server에서 백업을 복원하면 오류가 발생합니다
prod (Windows Server 2003의 SQL Server 2000)로 이동해야하는 데이터베이스 (Windows Server 2008의 SQL Server 2005)가 있습니다. 내 프로세스는 다음과 같습니다. dev에 로그인하여 SQL Server Management Studio를 엽니 다. 데이터베이스를 마우스 오른쪽 버튼으로 클릭하십시오 | 작업 | 지원. 모든 기본 옵션 유지 (전체 백업 등) .bak 파일을 로컬로 prod (네트워크 드라이브 …

3
전원 손실로 인한 SSD 손상을 방지 할 수있는 방법이 있습니까?
Linux, 로컬 웹 서버 및 PostgreSQL이 설치된 소비자 단말기 그룹이 있습니다. 문제가있는 기계에 대한 현장 보고서를 받고 있으며 조사 결과 정전이 발생한 것으로 보이며 이제 디스크에 문제가있는 것 같습니다. 문제는 데이터베이스가 손상되었거나 최근 변경 사항이있는 파일이 스크램블 된 것으로 가정했지만 다른 이상한 보고서가 있습니다. 권한이 잘못된 파일 디렉토리가 된 파일 …

3
LTO 테이프의 남은 용량 확인
LTO 테이프에 남은 공간을 어떻게 확인할 수 있습니까? 끝까지 찾고 상태를 확인하면 파일 번호 17에 있음을 알 수 있지만 알 수없는 것은 각 파일의 크기입니다. $ mt -f /dev/nst1 eod $ mt -f /dev/nst1 status SCSI 2 tape drive: File number=17, block number=0, partition=0. Tape block size 0 bytes. Density …
15 tape  lto 

5
치명적인 오류 : 권한 테이블을 열고 잠글 수 없음 : 'user'에 대한 테이블 스토리지 엔진에이 옵션이 없습니다.
이 오류 메시지는 Docker 이미지에서 우분투 16.04 및 최신 mysql 5.7.19-0ubuntu0.16.04.1을 사용할 때 나타납니다. 이 문제를 해결하기 위해 무엇을 할 수 있습니까? 오류를 재현하려면 를 가져 오기 Dockerfile: FROM ubuntu:16.04 RUN apt update RUN DEBIAN_FRONTEND=noninteractive apt install -y mysql-server ( 여기 에서도 사용 가능 ) 빌드하고 실행하십시오. docker build -t …
15 mysql  docker 

1
SSL 검사 rpm 비활성화
rpm 명령을 실행하려고하면 다음 오류가 발생합니다. 왜 컬 오류가 발생하는지 잘 모르겠지만 모두 실패한 여러 가지 옵션을 시도했습니다. CentOS7 실행 및 프록시 뒤 [root@CentOS7]# rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm Retrieving https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm curl: (60) Peer's certificate issuer has been marked as not trusted by the user. More details here: http://curl.haxx.se/docs/sslcerts.html curl performs SSL …
15 ssl  centos7  rpm  curl 

2
MacOS 클라이언트가 WPA Enterprise 무선 네트워크와 산발적으로 연결이 끊어짐
우리는 각각 20 명으로 구성된 소규모 사무실을 가지고 있으며 각각 MacBook을 사용하고 선택적으로 휴대폰과 연결됩니다. 이전에는 공유 키와 함께 일반적인 Wi-Fi를 사용했지만 최근에는 모든 사용자가 고유 한 자격 증명을받은 WPA Enterprise (로그인 / 암호 쌍)로 재구성했습니다. 인증은 freeradiusAWS EC2 박스에서 실행 되는 서비스를 통과합니다 . RADIUS 서버는 인증서를 사용하도록 구성되어 …

1
사용자가 journalctl을 사용하여 사용자 별 시스템 서비스 로그를 볼 수있게하는 방법은 무엇입니까?
Ubuntu 16.04 LTS에서 사용자 수준 서비스를 실행하고 있습니다. 예를 들어, test.service는 ~ / .config / systemd / user / test.service에 있습니다. 나는함으로써 서비스를 실행할 수있었습니다. systemctl --user start test.target 그러나 journalctl을 사용하여 로그를 읽으려고 할 때 다음 오류 메시지가 나타납니다. journalctl --user -u test.service Hint: You are currently not seeing …

4
SSH 세션의 총 대기 시간 측정
터널링 된 SSH 세션에서 전체 대기 시간 을 측정 /보고하는 방법이 있습니까? 내 특정 설정은 다음과 같습니다 클라이언트 (OS X + wifi 라우터 + ADSL 모뎀) 인터넷에 노출 된 게이트웨이 SSH 서버 터널링중인 내부 SSH 대상 로컬 컴퓨터의 콘솔과 세션을 연 최종 컴퓨터 간의 대기 시간을보고 싶습니다.

1
Nginx가없는 ELB 뒤의 Gunicorn에 대한 Keepalive 설정
우리의 응용 프로그램의 REST API는 (Gunicorn에 의해 제공됩니다 하지 전형적인 자동 스케일링 / 부하 분산 설치를 AWS EC2 인스턴스에서 실행 Nginx에 뒤에). 로드 밸런서의 유휴 시간 초과는 60 초이고 Gunicorn의 연결 유지 시간 초과는 2 초입니다. 504 Gateway Timeout이 구성에서 산발적 인 반응 이 나타났습니다 . Amazon docs 에 따르면 …

2
RFC 2782를 위반하여 CNAME 별칭을 가리키는 SRV 레코드가 게시 되었습니까?
몇 가지 업무를 수행하면서 SRV 레코드를 정리해야하며, Wikipedia 선언을 DNS 발굴에서보고있는 내용과 조정하려고합니다. 에 따르면 위키 백과의 SRV 레코드 항목 , SRV 레코드의 대상은 주소 레코드 (A 또는 AAAA 레코드)가있는 호스트 이름을 가리켜 야합니다. CNAME 레코드가있는 호스트 이름을 가리키는 것은 올바른 구성이 아닙니다. 그러나 digCNAME 레코드의 별칭 인 이름을 가리키는 …

1
Docker 캐시 무효화를 디버깅하는 방법?
Docker에는 캐시가 있지만 "docker build"출력에서 볼 수있는 것은 다음 중 하나입니다. ---> Using cache 또는 명령의 출력 (캐시를 사용하지 않음을 의미). Dockerfile (COPY)에서 한 단계 후에 캐시를 사용하지 않습니다. 그러나 나는 복사중인 폴더에서 아무것도 바뀌지 않았다고 확신합니다. (이것은 우리의 응용 프로그램이며, 예를 들어 연속으로 두 번 배포 할 때도 캐시가없는 …
15 docker 

3
10GigE에서 DRBD 끔찍한 동기화 성능
고 가용성 서비스를 호스팅하기 위해 RAID 어레이 (8 코어, 16GB RAM, 12x2TB RAID6), 3 개의 10GigE 인터페이스가있는 동일한 서버 쌍을 설정했습니다. 시스템은 현재 Debian 7.9 Wheezy oldstable을 실행하고 있습니다 (corosync / pacemaker는 8.x 안정도 및 테스트에서도 사용할 수 없기 때문에). 로컬 디스크 성능은 약 900MB / s 쓰기, 1600MB / …

2
Ansible을 사용하여 URI 요청에서 JSON 응답을 확인하는 방법은 무엇입니까?
JSON 응답을 얻기 위해 웹 사이트에 URI 요청을하는 Ansible 작업이 있습니다. 중첩 JSON 변수가 정의되어 있으면 Ansible이 무언가를하고 그렇지 않으면 다른 것을 원합니다. - name: Get JSON from the Interwebs uri: url="http://whatever.com/jsonresponse" return_content=yes register: json_response - name: Write nested JSON variable to disk copy: content={{json_response.json.nested1.nested2}} dest="/tmp/foo.txt" 사용하는 것을 참고 ignore_errors만하는 …
15 ansible 

2
아카이브 모듈이없는 이유는 무엇입니까?
에 대한 인터넷 검색 Ansible 타르를 만들 좋은 결과를 얻을하지 않습니다 그리고 거기에있는 동안 보관을 취소 모듈이 더 없다 아카이브 모듈. 아마도 명령 모듈로 해결할 것입니다. 그러나 Ansible의 새로운 기능은 내가 잘못하고 있다고 생각하게 만듭니다. 프로덕션 서버에 소스 코드를 업로드해야하는 taring이 필요한 첫 번째 사람이 아니라고 확신합니다. 그렇다면 왜 아카이브 …
15 ansible 

3
EC2 Linux "인식되지 않은 서비스"를 반환하는 모든 시작 작업
Ubuntu에서 EC2 Linux (ElasticBeanstalk)로 일부 시작 작업을 마이그레이션하는 악몽 가장 기본적인 작업조차 할 수 없습니다. 아래 스크립트를 사용하여 우분투에서 완벽하게 작동하지만 EC2 Linux에서 시작하려고 할 때 매우 도움이되지 않는 "인식되지 않은 서비스"를 반환합니다. 나는 이것이 일반적으로 구문 오류라는 것을 읽었지만 이것이 우분투에 대해 구문 적으로 괜찮다면 따르지 않습니다. 큰 도움을 …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.